autstat Support

icon
Avatar
kvoutet
Posts: 4
I have installed Flexarray 1.6.3, statconnDCOM 3.6-0B6 HomeStudent, rscproxy and rcom but Flexarray cannot connect to R.
Please help. I am phD student and I have to use Flexarray.
I have followed your debugging information and I post this:
Windows 7 ultimate version 6.1 (Build 7601:Service Pack 1)
"R version 3.4.0 (2017-04-21)"

R version 3.4.0 (2017-04-21)
Platform: i386-w64-mingw32/i386 (32-bit)
Running under: Windows 7 x64 (build 7601) Service Pack 1

Matrix products: default

locale:
[1] LC_COLLATE=Greek_Greece.1253 LC_CTYPE=Greek_Greece.1253
[3] LC_MONETARY=Greek_Greece.1253 LC_NUMERIC=C
[5] LC_TIME=Greek_Greece.1253

attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):
[1] compiler_3.4.0

Package
"rscproxy"
LibPath
"C:/Users/user/Documents/R/win-library/3.4"
Version
"2.0-5"
Priority
NA
Depends
NA
Imports
NA
LinkingTo
NA
Suggests
NA
Enhances
NA
License
"GPL-2"
License_is_FOSS
NA
License_restricts_use
NA
OS_type
NA
MD5sum
NA
NeedsCompilation
NA
Built
"3.0.0"



Package
"rcom"
LibPath
"C:/Users/user/Documents/R/win-library/3.4"
Version
"1.2.4"
Priority
NA
Depends
"R (>= 2.2.0)"
Imports
NA
LinkingTo
NA
Suggests
NA
Enhances
NA
License
"GPL Version 2 or later."
License_is_FOSS
NA
License_restricts_use
NA
OS_type
NA
MD5sum
NA
NeedsCompilation
NA
Built
"c(2, 3, 0)"


LicenseTest
Run-time error '2147221485'(80040013)
automation error




[2696] FTH: (2696): *** Fault tolerant heap shim applied to current process. This is usually due to previous crashes. ***
[2696] statconnDCOM Installation path is "C:\Program Files (x86)\statconn\DCOM"
[2696] BDXImpl_init(licensee=Testing, connector=R, parameters=(null), objptr=002F5B1C, installpath=C:\Program Files (x86)\statconn\DCOM, licensepath=C:\Program Files (x86)\statconn\DCOM
[2696] BDX_get_vtbl2: conn=R, licensee=Testing, objptr=0040B6A0, version=1, path=C:\Program Files (x86)\statconn\DCOM
[2696] BDX: DateTime enabled
[2696] BDX: Special .NET features enabled
[2696] BDX: x86 support (32bit) enabled
[2696] BDX: x64 support (64bit) enabled
[2696] H&S: Closing Splash Screen
[2696] ~SplashImpl
[2696] CStatConnector::initBDXForConnector() vtbl-object@1007B000
[2696] connector: R
[2696] DLL: rscproxy.dll
[2696] environment: R_HOME
[2696] registry key: Software\R-core\R
[2696] registry value: InstallPath
[2696] version key:
[2696] version value:
[2696] binary dir: bin/i386
[2696] connector: RPre2.12
[2696] DLL: rscproxy.dll
[2696] environment: R_HOME
[2696] registry key: Software\R-core\R
[2696] registry value: InstallPath
[2696] version key:
[2696] version value:
[2696] binary dir: bin
[2696] connector: Rold
[2696] DLL: rproxy.dll
[2696] environment: R_HOME
[2696] registry key: Software\R-core\R
[2696] registry value: InstallPath
[2696] version key:
[2696] version value:
[2696] binary dir: bin
[2696] connector: SciLab
[2696] DLL: sciproxy.dll
[2696] environment: SCILAB_HOME
[2696] registry key: Software\Scilab\%s
[2696] registry value: SCIPATH
[2696] version key: Software\Scilab
[2696] version value: LASTINSTALL
[2696] binary dir: bin
[2696] sc_proxy_find_connector: found "R"
[2696] sc_proxy_find_connector: found "R"
[2696] sc_proxy_load log follows!
[2696] sc_proxy_load: sc_proxy_find_connector(,<R>) done
[2696] sc_proxy_load: sc_proxy_find_connector(,<R>) done
[2696] Look up "R" in the registry
[2696] sc_proxy_load: use registry key "Software\R-core\R"
[2696] looking up registry key at "HKCU\Software\R-core\R\InstallPath"
[2696] looking up registry key at "HKLM\Software\R-core\R\InstallPath"
[2696] CStatConnector::~CStatConnector()

Thank you in advance!
2017-07-05 12:52
Avatar
Thomas Baier
Moderator
Posts: 115
The error code indicates that the rscproxy library is invalid. Where did you get it from?
2017-07-05 19:46
Avatar
kvoutet
Posts: 4
Thank you very much for your quick response. I installed rscproxy via Rstudio from archive because I couldn't find this package for R 3.4.0. I downloaded rscproxy_2.0-5.tar.gz from https://cran.r-project.org/src/contrib/Archive/rscproxy/.
The same procedure I followed also for rcom package...

Thank you in advance.
2017-07-06 09:17
Avatar
Thomas Baier
Moderator
Posts: 115
I do understand. Unfortunately the version from the CRAN archives won't work anymore, therefore they have been removed from the main repository. You can install and download the software from autstat.com repos. Unfortunately the versions for R 3.4 are currently only available for autstat customers. The free repo only contains software up to R 3.3.

The 3.4 versions will be available soon in the public repo, too. Most probably next week.

Thomas
2017-07-06 14:27
Avatar
kvoutet
Posts: 4
I installed R 3.3.0 but I cannot find the rscproxy package austat.com repos. Could you please give me more help? I need this package, right?
2017-07-06 15:15
Avatar
kvoutet
Posts: 4
o.k!I found it...Thank you!Everything is working now!
2017-07-06 15:35
icon